Ubuntu 9.04 – Conecta, pega ip, mas não navega!!!


Opa!!!

Tive outro dia um problema no Ubuntu 9.04 … Ele conectava, pegava ip, tudo direitinho, mas não navegava!

Como ninguém vive sem internet hoje, bateu aquele desespero!!! O que fazer!!

Olhava para as configurações…. Tudo certo … dhclient… pegava ip… tudo certinho…

Até que me atentei a uma coisa… MTU …

Você se pergunta!! Que p$#@$! é essa !???

Bom, MTU nada mais é que a unidade máxima de transmissão… Trocando em miúdos, a mtu controla o tamanho dos pacotes transmitidos entre dois ponto… (Acho que é isso mesmo ! rsrsrs)

A maioria das placas novas suportam MTU´s de até 1500 bytes…
Minha plaquinha é nova, mas, eu me recordo que a MTU configurada anteriormente era de 1482 … e o ubuntu colocou como 1500 …

Então, meu problema se resolveu com o seguinte comando …

Como root:

ifconfig eth0 mtu 1482

Coloque o dispositivo de acordo com as suas configurações…

Feito isto, a internet que estava mais pra lá do que pra cá, funcionou igual uma bala!!!

Espero ter ajudado!!

Abraços…

Fred Chevitarese – GNU/Linux

9 Respostas to “Ubuntu 9.04 – Conecta, pega ip, mas não navega!!!”

  1. Jaime Balbino Says:

    Ótima dica! Valeu a divulgação. O ajuste do MTU é algo muito obscuro, mesmo para especialistas.

  2. Paulo Henrique Says:

    Olá amigo,
    eu tenho um cce w93 e instalei o ubuntu 9.04 também. Porém ainda não consegui conectar na internet com wireless.
    Vc já conseguiu? Se sim me dê um luz por favor. =)

    Valeu!

    • Bom dia Paulo Henrique!!!

      Consegui sim!!!
      Bom, todos os problemas que tive de hardware, exceto a placa de vídeo, foram relacionados aos parâmetros de kernel…
      Até no meu artigo, tem uma discrepância, não um erro, a um parâmetro de kernel que é passado na hora do boot… Como eu descobri isto depois, eu nem lembrei de trocar no tutorial…
      O parâmetro que estava sendo passado incorretamente era o acpi=off… Na realidade tem de ser acpi=force…
      Daí, todos os “periféricos” do note passam a funcionar beleza…
      Não sei se isto é realmente seu problema, mas se for, acredito que será esta a solução 😉

      Abraços!!!

  3. Realmente perfeito. Fiquei umas 3 horas gogleando por ai para achar uma solução. E esse comando resolveu minha vida. Muito Obrigado!

  4. como
    configurar o dsn no ubuntu9.04

  5. Saudações a todos, fiz tudo o que li em vários tutoriais e nada adiantou, então tive a brilhante ideia de trocar de roteador e funcionou, o problema era no roteador. Mas não joguei o mesmo fora e sim o resetei e apenas coloquei a senha wpa2 e não mexi em mais nada e voilá, ele voltou a se conectar com o ubuntu instalado em um note hp 15-d038dx com wif rtl8188ee. Lembrando que no rwindows ele funcionava perfeitamente e no linux ele conectava, o ping dava retorno mas não era capaz de navegar na internet. Espero que alguém leia isto e seja ajudado por mim!

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: